
 

  

 
2017 Knowledge Based Preparation, Compilation, and Reviews of Not-for-Profit Entities 

November 2017 

CCH® ProSystem fx® Knowledge Coach 

Welcome to 2017 Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities for 
Knowledge Coach 

This Release Notes document provides important information about the 2017 release of Knowledge Based Preparation, Compilation, and 
Reviews of Not-for-Profit Entities. Please review this information carefully. If you have any questions, additional information is available on 
CCH Support Online. 

New in this Release  

Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities  
 
2017 Knowledge Based Preparation, Compilation, and Reviews of Not-for-Profit Entities can be installed on CCH® ProSystem fx® 
Engagement v7.5 by first installing the Engagement v7.5 and Knowledge Coach v2.5 August Update. This update will allow users to work on 
the 2017 Not-for-Profit Preparation, Compilation, and Reviews title without installing ProSystem fx Engagement v2017.1.3 until your firm 
plans to update. 

This title is designed to help the accountant efficiently and effectively perform financial statement preparation engagements, compilations, 
and reviews of nonpublic commercial entities in accordance with Statements on Standards for Accounting and Review Services (SSARS) 
issued by the Accounting and Review Services Committee (ARSC) of the American Institute of Certified Public Accountants (AICPA).  

The Knowledge-Based Preparation, Compilation, and Review (KBPCR) methodology emphasizes using knowledge of the entity to perform 
preparation, compilation, and review engagements by facilitating the flow of information so that the understanding obtained in each 
process affects the decisions made in the next. Although the accountant will likely perform most steps in this methodology sequentially, 
conducting an engagement is not necessarily a linear process. Knowledge gained from preliminary engagement activities helps the 
accountant design and customize engagement procedures; evidence gained from procedures performed is evaluated and the appropriate 
accountant’s report, if any, is issued. This edition includes specific up-to-date guidance for conducting preparation, compilation, and review 
engagements in accordance with the SSARS. 

Conducting preparation, compilation, and reviews of Not-for-Profit entities requires the exercise of the accountant’s professional 
judgment. This document is published for the purpose of communicating, to users of the toolset, updates and enhancements included in 
the current version. This document is not, and should not be used as a program to update the documentation of an engagement started in 
a previous version of this product. 

This document is published for the purpose of communicating the updates and enhancements included in the current version to users of 
the toolset. This document is not, and should not be used as an audit program to update the audit documentation of an engagement 
started in a previous version of this product. 

If you are updating from a previous version of this title, refer to the Knowledge Coach User Guide Chapter 12. The guide is found on the 
Engagement File Room Help menu.  

The 2017 documents include CCH® Accounting Research® material links to specific guidance that provides instant access to detailed analysis 
related to the steps and processes discussed in the workpapers.  

http://support.cch.com/productsupport/
https://support.cch.com/updates/Engagement/patch75/patch75.aspx
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This module includes separate titles for Preparation, Compilation, and Review Engagements.  Each title will need to be downloaded 
separately.   

2017 Edition of Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities  
This edition features numerous enhancements, including:  

• New and modified procedure steps and practice points for current accounting guidance noted below. 

• Adding many new AIDs, CORs, RPTs, and RESs as follows: 

o AID-301 Worksheet for Determination of Materiality, Performance Materiality, and Thresholds for Trivial Amounts 

o COR-201A Engagement Letter: Compilation of Financial Statements Prepared By Client in Accordance with U.S. GAAP 

o COR-201D Engagement Letter: Compilation of Prospective Financial Statements (Forecast) 

o COR-201E Engagement Letter: Compilation of Prospective Financial Statements (Projection) 

o COR-209A Engagement Letter: Review of U.S. GAAP Financial Statements Prepared by Client 

o RES-004 Determination of Materiality, Performance Materiality, and Thresholds for Trivial Amounts 

o RPT-0914 Compilation Report: Prospective Financial Statements—Forecast 

o RPT-0915 Compilation Report: Prospective Financial Statements—Projection 

 

Click here for the 2017 Preparation, Compilation, and Reviews of Not-for-Profit Title Overview for Knowledge Coach Users. 

In addition, forms and practice aids throughout have been updated to include new examples and tips, and where applicable, to take into 
account: 

New literature, standards, and developments, reflected in the following current audit and accounting guidance:  

• SSARS No. 23, Omnibus Statement on Standards for Accounting and Review Services - 2016 

• AICPA Guide Preparation, Compilation and Review Engagements; 

• AICPA Statement on Quality Control Standards No. 8 (QC Section 10), A Firm's System of Quality Control (Redrafted); 

• Revised AICPA Code of Professional Conduct (Code), including ET Section 1.295, Nonattest Services; and 

• 2016/2017 Audit Risk Alert Developments in Review, Compilation, and Financial Statement Preparation Engagements – 2016/17. 

• FASB Accounting Standards Codification as of September 30, 2017, and through Accounting Standards Update (ASU) No. 2017-13, 
including: 

o ASU ASU No. 2017-11, Earnings Per Share (Topic 260); Distinguishing Liabilities from Equity (Topic 480); Derivatives and 
Hedging (Topic 815): (Part I) Accounting for Certain Financial Instruments with Down Round Features, (Part II) 
Replacement of the Indefinite Deferral for Mandatorily Redeemable Financial Instruments of Certain Nonpublic Entities 
and Certain Mandatorily Redeemable Noncontrolling Interests with a Scope Exception 

o ASU No. 2017-12, Derivatives and Hedging (Topic 815): Targeted Improvements to Accounting for Hedging Activities; and 

o ASU No. 2017-13, Revenue Recognition (Topic 605), Revenue from Contracts with Customers (Topic 606), Leases (Topic 
840), and Leases (Topic 842): Amendments to SEC Paragraphs Pursuant to the Staff Announcement at the July 20, 2017 
EITF Meeting and Rescission of Prior SEC Staff Announcements and Observer Comments. 

http://support.cch.com/updates/KnowledgeCoach/pdf/guides_tab/2017%20NFP%20PCR%20Title%20Overview%20for%20Knowledge%20Coach%20Users.pdf
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Important Notes: 

• Make sure to save changes to workpapers before closing the workpaper or the binder to ensure data is correctly updated. 

• If your Current Editor Knowledge Coach Microsoft® Word workpapers become read-only or crash, please do the following: 

– Keep the binder with the affected workpapers open. 

– Highlight the workpaper in the binder window and go to Tools > Save Knowledge Coach Answers. 

System Requirements 

• This title requires the 2017 Financial Statement Base Title. The 2017 Financial Statement Base title MUST be installed with one of 
the following versions of CCH® ProSystem fx ® Engagement and Knowledge Coach.  

– Engagement v7.5.100.1223 and Knowledge Coach v2.5.100.1224 available through the ProSystem fx Engagement v7.5 and 
Knowledge Coach v2.5 August Update. To identify what version you are running, please go to the Help > About window 
within the application.  

– Engagement and Knowledge Coach v2017.1.3 or later. 

• A minimum of 4GB of RAM is required for optimal performance when opening and navigating through Knowledge Coach 
workpapers. 

License Requirements 

This title requires the Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities license.  
Any user that does not have a license for this title will not be able to use Knowledge Coach functionality in workpapers.  

For more information on how to update your licensing, view How do I add or update CCH ProSystem fx Engagement Licenses? on our 
website.  

For more information on how to assign licenses, view How do I assign Engagement Licenses? on our website. 

Download Instructions 

If you are planning to use this title on Engagement v7.5 and Knowledge Coach v2.5, ensure you apply ProSystem fx Engagement v7.5 and 
Knowledge Coach v2.5 July Update to all machines including Admin servers and terminal servers before installing the title. Review the July 
Update release notes for more information on deployment. 

To download this title: 

1. Navigate to the Knowledge Coach Updates section of the Engagement Support Website.  

2. Select the Knowledge Coach Series. The series are arranged by title type, then industry. 

3. Click on the Download File link next to the title you wish to download. 

Note: On some occasions the content package file (.KCP) will download with the extension changed to .ZIP. If this occurs, please change the 
extension of the downloaded file to KCP using all capital letters. 

You must install the 2017 Financial Statement Base title before installing the 2017 Knowledge Based Preparation, Compilation, and Reviews 
of Not-for-Profit Entities.  

The Financial Statement Base title is also available on the Knowledge Coach Update Website.    

https://support.cch.com/kb/solution.aspx/sw3937
https://support.cch.com/kb/solution.aspx/sw3943
https://support.cch.com/updates/Engagement/patch75/Engagement%20and%20KC%20July%202017%20Update%20Release%20Notes.pdf
http://support.cch.com/updates/KnowledgeCoach
http://support.cch.com/updates/KnowledgeCoach
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The Knowledge Coach Content Package (KCP) download is a proprietary file that must be installed from within Engagement. Save this KCP 
file to a location on your local drive, and follow the Installation Instructions below. 

Installation Instructions 

Once you have downloaded your Knowledge Coach title, you will need to add it to the list of titles within CCH ProSystem fx Engagement. 
The only additional system requirement is approximately 75MB of disk space to store your Knowledge Coach Program content files. Please 
refer to the Engagement with Knowledge Coach Release Notes for any other system requirements.  

After downloading the 2017 Knowledge Based Preparation, Compilation, and Reviews of Not-for-Profit Entities, do the following: 

1. Launch the Engagement Workpaper Management application so that the Local File Room is displayed. Select Tools > Knowledge 
Coach Titles.  

2. The Knowledge Coach Titles window will be displayed.  

3. Choose Add Title.  

4. Browse to the title package file (*.KCP) that you previously downloaded from the Knowledge Coach Support Web site.  

5. Choose Open.  

6. The system will display a progress indicator while the title package is added. You will receive a message that the title has been 
successfully installed once the process is complete. 

To release a title:  

1. Select one of the Knowledge Coach titles in the list that has been added but is not yet released.  

2. Choose Release Title. The current date and time will be displayed in the Date released column, and the status will change to 
“Released.”  

Note: In the Engagement Admin module, add and assign a Knowledge Coach module and the applicable Knowledge Coach title license to 
staff before using the workpapers. 

Important: Once the 2017 Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities title has been added and 
released, they will be automatically deployed to other staff members when they login to the “Office” location, or when they synchronize a 
binder that contains Knowledge Coach workpapers from this title.  

Online Permission Key 

Permission key files may be downloaded from our website or when adding or updating the new licenses within CCH ProSystem fx 
Engagement with Knowledge Coach v7.5 and higher. After updating the license file in the Engagement Admin module, licenses need to be 
assigned to the staff who will use 2017 Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities. 

If you have not already established a Single Sign-on (SSO) account with Customer Service, we urge you to do so at this time.  

CCH® Accounting Research Manager® 

CCH’s Accounting Research Manager (ARM) is the most comprehensive, up-to-date and objective online database of financial reporting 
literature. It includes all authoritative and proposed accounting, auditing, and SEC literature, plus independent, expert-written interpretive 
guidance.  

https://prosystemfxsupport.tax.cchgroup.com/permkey/download.aspx
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Available on ARM, the Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities Guide helps you comply with the 
most recent professional standards and guidance for the conduct of preparations, compilations, and reviews of Not-for-Profit Entities and 
to integrate the use of practice aids, tools, and other resources with its guidance. This publication supplements and complements the 
Knowledge-Based documents that are available in Knowledge Coach. 

If you subscribe to an ARM library that includes Not-for-Profit content, you can link directly to source material from Resources within 
Knowledge Coach documents. These links have been updated to refer to the accounting standards under the FASB Accounting Standards 
Codifications. Also, if you subscribe to the Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities Guide on 
ARM, you can take advantage of references to the guide material from within the Knowledge Coach documents.  

With Accounting Research Manager, you maximize the efficiency of your research time, while enhancing your results. Learn more about our 
content, our experts, and how you can request your free trial by visiting the Accounting Research Manager website. You can also access the 
Accounting Research Manager Web site by selecting Engagement > Binder Window > Shortcuts Bar > Guidance tab.  

Using Your Knowledge Coach Content 
To use your Knowledge Coach Workpaper Templates, do the following: 

1. Open a binder in Engagement. 

2. Select the workpaper tab into which you would like to insert the workpaper. 

3. Select New Knowledge Coach Workpaper from the toolbar or File menu. 

4. The New Knowledge Coach Workpaper dialog appears (Figure 1).  

5. Select the New Knowledge Coach Title with the content you would like to use. You can only select titles you have installed. The 
information displayed changes to reflect the workpaper organization available for the selected title.  

6. Select the Knowledge Coach Workpapers to insert into your binder and click OK.  

7. In the Selected Workpaper Properties dialog, each workpaper name is automatically loaded into the Name field. Add a workpaper 
index in the Index field and make any Name modifications you desire. You can also modify the tab location or the roll forward 
settings for each workpaper. 

8. Click OK. The integrated Knowledge Coach workpaper is now inserted into your engagement binder.  

Note: For more information on how to use Knowledge Coach workpapers in your binder, see the Knowledge Coach User Guide.  

http://www.accountingresearchmanager.com/
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Additional Information on Knowledge Coach and the KBA Methodology 

Knowledge-Based Preparation, Compilation, and Review (KBPCR) Methodology 
Allows the results of one set of procedures to become the input for the next. The key components of the KBPCR methodology include: 
 

• An Overview that guides accountants through the methodology; 

• Knowledge-Based Preparation, Compilation, and Review documents, integral to the risk assessment and overall audit processes, 
which contain steps and procedures required by SSARS; 

Figure 1 - New Knowledge Coach Workpaper 
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• Customizable Preparation, Compilation, and Review Programs that take accountants through related steps and procedures; 

• Practice Aids to help accountants complete steps or processes outlined in the Knowledge-Based Preparation, Compilation, and 
Review documents and Programs; 

• Accountant’s Reports that provide a variety of sample accountant’s opinions on audited financial statements; and 

• Correspondence documents that provide sample letters to be used to comply with SSARS requirements and in many other 
common situations. 

• The AICPA’s Accounting and Review Services Committee (ARSC) SSARS - The practice aids and tools in the 2017 Knowledge-Based 
Preparation, Compilation, and Reviews of Not-for-Profit Entities are designed around the AICPA’s SSARS standards to assist 
accountants by: 

– Facilitating compliance with SSARS; 

– Encouraging more effective engagements through tailored engagement programs and comprehensive practice aids; and 

– Enhancing audit documentation. 

CCH® ProSystem fx® Knowledge Coach 

Knowledge Coach functionality allows accountants to use the Knowledge-Based methodology more efficiently by eliminating the need for 
duplicate entry of the same information, tailoring documentation to each particular engagement, and documenting the link between risks 
identified and procedures performed. PRP-100 Tailoring Question Workpaper, CMP-100 Tailoring Question Workpaper or REV-100 Tailoring 
Question Workpaper is a document in Knowledge Coach that presents engagement-level questions designed to aid in tailoring the 
engagement documentation to fit each client. Completing the questions helps the accountant avoid duplication and unnecessary 
workpapers.  

Note: Before you begin your engagement, please review the guidance in PRP-101 Overall Preparation Program, CMP-101 Overall 
Compilation Program or REV-101 Overall Review Program. This workpaper is intended to be your road map through a Knowledge-Based 
Audit methodology. You should start your audit with PRP-100 Tailoring Question Workpaper, CMP-100 Tailoring Question Workpaper or 
REV-100 Tailoring Question Workpaper and PRP-101 Overall Preparation Program, CMP-101 Overall Compilation Program or REV-101 
Overall Review. 

• Risks  
The Risk Assessment features have been disabled since the 2012 Knowledge-Based Compilations and Review Title for Knowledge 
Coach. Refer to KBP-101 Preparation: Significant Matters, KBC-101 Compilation: Significant Matters and KBR-102 Review: Significant 
Matters to accumulate and review significant issues and findings. PRP-801 Preparation Program, CMP-801 Compilation Program: 
Significant Risks and Uncertainties and REV-802 Review Program: Significant Risks and Uncertainties provides a guide for 
implementing the guidance related to the disclosure of certain significant risks and uncertainties. 

• Information Flow  
Helps cut down on the time spent duplicating information across forms. In addition, the flow of consistent information ensures that 
information and updates to information are not missed between workpapers. Drill-down functionality helps the user navigate 
quickly to the source of the information, aiding in the review of the engagement file. 

• Diagnostics  
Help keep track of unresolved issues like unanswered questions, incomplete risks, program steps not linked to risks or relevant 
assertions, missing workpaper, and more.  

• Links to Accounting Research Manager (ARM) 
If you subscribe to an ARM library that includes accounting content, you can link directly to source material from Resources within 
Knowledge Coach workpapers. These links have been updated to reference to the accounting standards under the SSARS and 
accounting standards issued by the AICPA. Also, if you subscribe to the Knowledge-Based Preparations, Compilations and Reviews 
of Not-for-Profit Entities Guide on ARM, you can take advantage of links to the guide material from within the Knowledge Coach 
documents. 
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• Interpretive Guidance 
It is integrated into each Knowledge Coach template through the Tips view of each new task pane. Informational features include 
Practice Points, Examples, Optional Workpapers, and Resources to help accountants work more effectively and efficiently. You can 
also navigate from Resources within a document or the tip pane directly to CCH’s Accounting Research Manager and industry 
guides by simply clicking on the Reference.  

 
 

Download Description: 2017 Knowledge-Based Preparation, Compilation, and Reviews of Not-for-Profit Entities (11/16/2017) 

Version: 

Engagement v7.5 and Knowledge Coach v2.5 with Engagement v7.5 and Knowledge Coach v2.5 July 
Update  
OR  
Engagement and Knowledge Coach v2017.1 or later 

2017 Financial Statement Base 

Release Date: November 2017 

File size: 18MB 

Approx. Download Time: 42 minutes at 56 kbps 

License: Full Version 

Platforms: Windows® 7, 8.1, 10 

Office: Microsoft® Office 2013 or higher required 
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